Updating HAProxy on Ubuntu/Debian

Ubuntu 14.04 LTS provide HAProxy 1.3 by default. Although it would sufficient for basic load balancer, there are some important updates and specific parameters that can only run on the updated HaProxy.

haproxy

Updating haproxy to the latest version relatively simple and straightforward as below :

Add new repository for haproxy latest update :

sudo add-apt-repository ppa:vbernat/haproxy-1.6

Press ENTER to save APT configuration file, then run the following command :

sudo apt-get update
sudo apt-get install haproxy

For installation procedure on Debian or others Ubuntu version or if you wish to check new update, simply open the following link : http://haproxy.debian.net/

Leave a Reply