Zimbra has published a new update for Zimbra Mail Server & Collaboration Suite, Zimbra 5.0.22 and Zimbra 6.0.5. This is the first update since VMWare acquired Zimbra. I would like to test it to see whether status & logger problem on Zimbra 6.0.4 has been officially solved or not.
I’m currently testing Zimbra 6.0.5 64 bit installation on SLES 11 64 bit, using Xen Hypervisor Guest (paravirtualization). The installation went smooth with only a few modification on SLES as describe below :

  1. Install SLES on text or server mode to prevent any unused services
  2. Edit your /etc/hosts so it will looks like below (change 127.0.0.2 with your Zimbra IP, mine is 192.168.0.31) :
    [code language=’cpp’]
    127.0.0.1 localhost
    192.168.0.31 hostname.domain.tld hostname
    [/code]
  3. Add sysstat package using YAST | Software | Software Management or by using  Zypper. Zimbra need another package such as  cron, fetchmail etc, but the installation process has installed all of them by default.
    [code language=’cpp’]
    zypper in sysstat
    [/code]
  4. Set your DNS so  A and MX records address will point to  Zimbra. I’ve published an article regarding DNS Server configuration to meet with Zimbra Requirement.
  5. Disable Postfix  :
    [code language=’cpp’]
    service postfix stop
    chkconfig postfix off
    [/code]
  6. Download Zimbra binary installer
    [code language=’cpp’]
    cd /opt
    wget -c http://h.yimg.com/lo/downloads/6.0.5_GA/zcs-6.0.5_GA_2213.SLES11_64.20100202233758.tgz
    [/code]
  7. decompress, run the installation script and then follow the wizard
    [code language=’cpp’]
    tar -zxvf zcs-6.0.5_GA_2213.SLES11_64.20100202233758.tgz
    cd zcs-6.0.5_GA_2213.SLES11_64.20100202233758
    sh install.sh
    [/code]


16 thoughts on “Installing Zimbra 6.0.5 64 bit on SLES 11 64 bit”
  1. Halo Mr Vavai,
    saya coba install zimbra 6.0.5 versi 32bit utk di install di opensuse 11.1
    tapi muncul error sbb:
    /usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/i586-linux-thread-multi/auto/Data/UUID/UUID.so: undefined symbol: Perl_Tstack_sp_ptr
    instalasi menggunakan script zimbra-auto.tar.gz
    apa pernah ngalaim hal spt diatas? dan bagaimana utk solusiny?
    trims b4

  2. Hi I followed this guide and everething is working exept that the “stats” service is not running, and in the last image there are x in the services, the stats page is asking for flashplayer too.
    Thanks

  3. Hi Easgs,
    Do you install it on SLES 11 or on openSUSE 11.1 ? Stats and service status on Zimbra 6.0.x+openSUSE need a modification to syslog as mentioned by Sappokus on his blog link. If you install it on SLES 11 as shown in my title, just wait for a few moment until it appeared correctly. Just click on refresh button on the service status.
    The stats page need a flashplayer and it is not Zimbra problem. Just install flashplayer plugin onto your browser and it should not complaining anymore.

  4. I used SLES 11 64 bit, and I have leave the server on for hours and the service doesn`t start, sometimes when restarting the server it start for a few minutes to later stop itself, I am testing this in a virtual vmware lan and the server sends and recieve the email, the only problem that I have found is this.
    By the way, is there a guide to install flash player in SLES 11 64bit, I have installed the rpm from the adobe site and it didn`t work.
    Thanks

  5. I have an issue with Zimbra Release 6.0.5 64 bit, after the installation, STATS is working perfectly but after 1month, it suddenly stop. I check everything and only stats is the one that stopped.

  6. @Genesis,
    Check the permission for folder /opt/zimbra/zmstat. It’s a bug on Zimbra 6.0.5 (and also on 6.0.6), sometimes the permission folder doesn’t correctly owned by Zimbra.
    Solution : chown -R zimbra:zimbra /opt/zimbra/zmstat

  7. @Genesis,
    Sorry, forgot to restart your Zimbra stat service.
    Solution :
    chown -R zimbra:zimbra /opt/zimbra/zmstat
    and then
    su – zimbra
    zmstatctl stop
    zmstatctl start
    Wait for a few minutes or more after all service status refresh dan displayed correctly.

  8. Thanks Vavai, i will check this one and i’ll let you know what will happen to my issue. Thanks for the response…

  9. Have you try NetRaid backup for Zimbra? I didnt try yet about Zimbra on DRBD but I want to know if you up this as the same setup from your Zimbra mail server. If you did, may i request to know the HOWTO. Thank you so much..

  10. Hi Vavai, I’ve check my Zimbra regarding about the STATS and the zmstat is already owned by Zimbra. I verify the permissions and still the STATS is stopped after restart the service. Thank you.

  11. Hi Vavai, just want to ask if there’s a way that i can filter the spam mails under zimbra server web gui and filter the spam mails and not by user?

Leave a Reply to dedy Cancel reply

Your email address will not be published.